use strict;
my $str = 'https://www2.website.com/forum/index.php?threads/redimensionner-une-image.8314/
https://www2.website.com
http://www2.website.com/
https://www.website.com/
http://www.website.com/
https://www2.website.com/engine/search?name=&description=&file=&uploader=&category=2145&sub_category=all&do=search
https://www2.website.com/team/
https://www2.website.com/team
https://www2.website.com/forum/index.php
website.com/team
website.com/forum
http://website.com/team
https://website.com/forum
https://website.com/forum/test
https://www.website.com
http://website.com
website.com/test
website.com
website.com/
http://website.com
https://website.com
https://www.website.com
http://website.com
test http://website.com test https://website.com/forum or website.com/test
https://www.test.com
https://sub.website.com';
my $regex = qr/\b(?:https?:\/\/)?(?:\w+\.)*website\.com(?!\/team|\/forum)\S*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}