import Foundation
let pattern = #"\b(?:https?:\/\/)?(?:\w+\.)*website\.com(?!\/team|\/forum)\S*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://www2.website.com/forum/index.php?threads/redimensionner-une-image.8314/
https://www2.website.com
http://www2.website.com/
https://www.website.com/
http://www.website.com/
https://www2.website.com/engine/search?name=&description=&file=&uploader=&category=2145&sub_category=all&do=search
https://www2.website.com/team/
https://www2.website.com/team
https://www2.website.com/forum/index.php
website.com/team
website.com/forum
http://website.com/team
https://website.com/forum
https://website.com/forum/test
https://www.website.com
http://website.com
website.com/test
website.com
website.com/
http://website.com
https://website.com
https://www.website.com
http://website.com
test http://website.com test https://website.com/forum or website.com/test
https://www.test.com
https://sub.website.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)