$re = '/\b(?:https?:\/\/)?(?:\w+\.)*website\.com(?!\/team|\/forum)\S*/m';
$str = 'https://www2.website.com/forum/index.php?threads/redimensionner-une-image.8314/
https://www2.website.com
http://www2.website.com/
https://www.website.com/
http://www.website.com/
https://www2.website.com/engine/search?name=&description=&file=&uploader=&category=2145&sub_category=all&do=search
https://www2.website.com/team/
https://www2.website.com/team
https://www2.website.com/forum/index.php
website.com/team
website.com/forum
http://website.com/team
https://website.com/forum
https://website.com/forum/test
https://www.website.com
http://website.com
website.com/test
website.com
website.com/
http://website.com
https://website.com
https://www.website.com
http://website.com
test http://website.com test https://website.com/forum or website.com/test
https://www.test.com
https://sub.website.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);