import re
regex = re.compile(r"\b(?:https?:\/\/)?(?:\w+\.)*website\.com(?!\/team|\/forum)\S*", flags=re.MULTILINE)
test_str = ("https://www2.website.com/forum/index.php?threads/redimensionner-une-image.8314/\n"
"https://www2.website.com\n"
"http://www2.website.com/\n"
"https://www.website.com/\n"
"http://www.website.com/\n"
"https://www2.website.com/engine/search?name=&description=&file=&uploader=&category=2145&sub_category=all&do=search\n"
"https://www2.website.com/team/\n"
"https://www2.website.com/team\n"
"https://www2.website.com/forum/index.php\n\n\n"
"website.com/team\n"
"website.com/forum\n"
"http://website.com/team\n"
"https://website.com/forum\n"
"https://website.com/forum/test\n\n"
"https://www.website.com\n"
"http://website.com\n"
"website.com/test\n"
"website.com\n"
"website.com/\n"
"http://website.com\n"
"https://website.com\n"
"https://www.website.com\n"
"http://website.com\n\n"
"test http://website.com test https://website.com/forum or website.com/test\n\n"
"https://www.test.com\n"
"https://sub.website.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")