# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\/|(?!^)\G)\d(?=\d*(?:\/|$))/$1X/gm;t' <<< "/users/12345
/users/234567/summary
/api/v1/summary/5678
http://example.com/api/v1/summary/5678/single"