const regex = new RegExp('(/|(?!^)\\G)\\d(?=\\d*(?:/|$))', 'gm')
const str = `/users/12345
/users/234567/summary
/api/v1/summary/5678
http://example.com/api/v1/summary/5678/single`;
const subst = `$1X`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);