# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(/|(?!^)\G)\d(?=\d*(?:/|$))"
test_str = ("/users/12345\n"
"/users/234567/summary\n"
"/api/v1/summary/5678\n"
"http://example.com/api/v1/summary/5678/single")
subst = "$1X"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.