import Foundation
let pattern = #"(/|(?!^)\G)\d(?=\d*(?:/|$))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/users/12345
/users/234567/summary
/api/v1/summary/5678
http://example.com/api/v1/summary/5678/single
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1X"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)