$re = '~(/|(?!^)\G)\d(?=\d*(?:/|$))~m';
$str = '/users/12345
/users/234567/summary
/api/v1/summary/5678
http://example.com/api/v1/summary/5678/single';
$subst = "$1X";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;