#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(/|(?!^)\G)\d(?=\d*(?:/|$))"
Local $sString = "/users/12345" & @CRLF & _
"/users/234567/summary" & @CRLF & _
"/api/v1/summary/5678" & @CRLF & _
"http://example.com/api/v1/summary/5678/single"
Local $sSubst = "$1X"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)