#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:^|[^\$])\${(?:(?P<section>[a-zA-Z0-9\-_]+?)\:)??(?P<key>[a-zA-Z0-9\-_]+?)(?:\[(?P<index>[0-9]+?)\])??\}"
Local $sString = "$${var3}" & @CRLF & _
"${section:var}" & @CRLF & _
"${section:var[11]}" & @CRLF & _
"${var3[0]}-${var3}-$${section2:var3[0]}-${section2:var3}-" & @CRLF & _
"" & @CRLF & _
"tintin-${var3}-${section2:var3[0]}-${section2:var3}- " & @CRLF & _
"" & @CRLF & _
"'this will be repeated forever${${${${${${${${${${${${${${${${var0h}}}}}}}}}}}}}}}}." & @CRLF & _
"values ValueList: var10: ['${var1}[999]'] " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")