re = /(?:^|[^\$])\${(?:(?P<section>[a-zA-Z0-9\-_]+?)\:)??(?P<key>[a-zA-Z0-9\-_]+?)(?:\[(?P<index>[0-9]+?)\])??\}/
str = '$${var3}
${section:var}
${section:var[11]}
${var3[0]}-${var3}-$${section2:var3[0]}-${section2:var3}-
tintin-${var3}-${section2:var3[0]}-${section2:var3}-
\'this will be repeated forever${${${${${${${${${${${${${${${${var0h}}}}}}}}}}}}}}}}.
values ValueList: var10: [\'${var1}[999]\']
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end