import Foundation
let pattern = #"(?:^|[^\$])\${(?:(?P<section>[a-zA-Z0-9\-_]+?)\:)??(?P<key>[a-zA-Z0-9\-_]+?)(?:\[(?P<index>[0-9]+?)\])??\}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
$${var3}
${section:var}
${section:var[11]}
${var3[0]}-${var3}-$${section2:var3[0]}-${section2:var3}-
tintin-${var3}-${section2:var3[0]}-${section2:var3}-
'this will be repeated forever${${${${${${${${${${${${${${${${var0h}}}}}}}}}}}}}}}}.
values ValueList: var10: ['${var1}[999]']
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)