const regex = /(?:^|[^\$])\${(?:(?P<section>[a-zA-Z0-9\-_]+?)\:)??(?P<key>[a-zA-Z0-9\-_]+?)(?:\[(?P<index>[0-9]+?)\])??\}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|[^\\$])\\${(?:(?P<section>[a-zA-Z0-9\\-_]+?)\\:)??(?P<key>[a-zA-Z0-9\\-_]+?)(?:\\[(?P<index>[0-9]+?)\\])??\\}', 'g')
const str = `\$\${var3}
\${section:var}
\${section:var[11]}
\${var3[0]}-\${var3}-\$\${section2:var3[0]}-\${section2:var3}-
tintin-\${var3}-\${section2:var3[0]}-\${section2:var3}-
'this will be repeated forever\${\${\${\${\${\${\${\${\${\${\${\${\${\${\${\${var0h}}}}}}}}}}}}}}}}.
values ValueList: var10: ['\${var1}[999]']
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}