// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:^|[^\$])\${(?:(?P<section>[a-zA-Z0-9\-_]+?)\:)??(?P<key>[a-zA-Z0-9\-_]+?)(?:\[(?P<index>[0-9]+?)\])??\}").unwrap();
let string = "$${var3}
${section:var}
${section:var[11]}
${var3[0]}-${var3}-$${section2:var3[0]}-${section2:var3}-
tintin-${var3}-${section2:var3[0]}-${section2:var3}-
'this will be repeated forever${${${${${${${${${${${${${${${${var0h}}}}}}}}}}}}}}}}.
values ValueList: var10: ['${var1}[999]']
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}