use strict;
my $str = '$${var3}
${section:var}
${section:var[11]}
${var3[0]}-${var3}-$${section2:var3[0]}-${section2:var3}-
tintin-${var3}-${section2:var3[0]}-${section2:var3}-
\'this will be repeated forever${${${${${${${${${${${${${${${${var0h}}}}}}}}}}}}}}}}.
values ValueList: var10: [\'${var1}[999]\']
';
my $regex = qr/(?:^|[^\$])\${(?:(?P<section>[a-zA-Z0-9\-_]+?)\:)??(?P<key>[a-zA-Z0-9\-_]+?)(?:\[(?P<index>[0-9]+?)\])??\}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}