#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!^([a-z]+|[A-Z]+|\d+|[\W_]+)$).{4,20}$"
Local $sString = "aaaaaaaaa" & @CRLF & _
"111111111" & @CRLF & _
"AAAAAAAA" & @CRLF & _
"!@#!@#!@" & @CRLF & _
"aaaaa11111" & @CRLF & _
"aaaaaAAAAA" & @CRLF & _
"aaaaa!@#@!" & @CRLF & _
"11111aaaaa" & @CRLF & _
"11111AAAAA" & @CRLF & _
"11111!@!@$" & @CRLF & _
"AAAAAaaaaa" & @CRLF & _
"AAAAA11111" & @CRLF & _
"AAAAA12312" & @CRLF & _
"!@#$%&aaaa" & @CRLF & _
"!@#$%&1231" & @CRLF & _
"!@#$%&AAAA" & @CRLF & _
"1123as%@#%AAFFSS" & @CRLF & _
"sdffsg#$52ERgWAfW14" & @CRLF & _
"sdffsg#$52ERgWAfW141" & @CRLF & _
"sdffsg#$52ERgWAfW1412" & @CRLF & _
"__________" & @CRLF & _
"----------" & @CRLF & _
"||||||||||" & @CRLF & _
"¹¹¹¹¹¹¹¹¹¹" & @CRLF & _
"²²²²²²²²²²" & @CRLF & _
"³³³³³³³³³" & @CRLF & _
"££££££££" & @CRLF & _
"¢¢¢¢¢¢¢¢¢¢" & @CRLF & _
"¬¬¬¬¬¬¬¬¬¬" & @CRLF & _
"//////////" & @CRLF & _
"°°°°°°°°°°" & @CRLF & _
"ªªªªªªªªªªª" & @CRLF & _
"aaaaaaaaaaaaa" & @CRLF & _
"ºººººººººººººº" & @CRLF & _
"₢₢₢₢₢₢₢₢₢₢₢₢₢₢"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")