using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!^([a-z]+|[A-Z]+|\d+|[\W_]+)$).{4,20}$";
string input = @"aaaaaaaaa
111111111
AAAAAAAA
!@#!@#!@
aaaaa11111
aaaaaAAAAA
aaaaa!@#@!
11111aaaaa
11111AAAAA
11111!@!@$
AAAAAaaaaa
AAAAA11111
AAAAA12312
!@#$%&aaaa
!@#$%&1231
!@#$%&AAAA
1123as%@#%AAFFSS
sdffsg#$52ERgWAfW14
sdffsg#$52ERgWAfW141
sdffsg#$52ERgWAfW1412
__________
----------
||||||||||
¹¹¹¹¹¹¹¹¹¹
²²²²²²²²²²
³³³³³³³³³
££££££££
¢¢¢¢¢¢¢¢¢¢
¬¬¬¬¬¬¬¬¬¬
//////////
°°°°°°°°°°
ªªªªªªªªªªª
aaaaaaaaaaaaa
ºººººººººººººº
₢₢₢₢₢₢₢₢₢₢₢₢₢₢";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}