const regex = /^(?!^([a-z]+|[A-Z]+|\d+|[\W_]+)$).{4,20}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!^([a-z]+|[A-Z]+|\\d+|[\\W_]+)$).{4,20}$', 'gm')
const str = `aaaaaaaaa
111111111
AAAAAAAA
!@#!@#!@
aaaaa11111
aaaaaAAAAA
aaaaa!@#@!
11111aaaaa
11111AAAAA
11111!@!@\$
AAAAAaaaaa
AAAAA11111
AAAAA12312
!@#\$%&aaaa
!@#\$%&1231
!@#\$%&AAAA
1123as%@#%AAFFSS
sdffsg#\$52ERgWAfW14
sdffsg#\$52ERgWAfW141
sdffsg#\$52ERgWAfW1412
__________
----------
||||||||||
¹¹¹¹¹¹¹¹¹¹
²²²²²²²²²²
³³³³³³³³³
££££££££
¢¢¢¢¢¢¢¢¢¢
¬¬¬¬¬¬¬¬¬¬
//////////
°°°°°°°°°°
ªªªªªªªªªªª
aaaaaaaaaaaaa
ºººººººººººººº
₢₢₢₢₢₢₢₢₢₢₢₢₢₢`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}