use strict;
my $str = 'aaaaaaaaa
111111111
AAAAAAAA
!@#!@#!@
aaaaa11111
aaaaaAAAAA
aaaaa!@#@!
11111aaaaa
11111AAAAA
11111!@!@$
AAAAAaaaaa
AAAAA11111
AAAAA12312
!@#$%&aaaa
!@#$%&1231
!@#$%&AAAA
1123as%@#%AAFFSS
sdffsg#$52ERgWAfW14
sdffsg#$52ERgWAfW141
sdffsg#$52ERgWAfW1412
__________
----------
||||||||||
¹¹¹¹¹¹¹¹¹¹
²²²²²²²²²²
³³³³³³³³³
££££££££
¢¢¢¢¢¢¢¢¢¢
¬¬¬¬¬¬¬¬¬¬
//////////
°°°°°°°°°°
ªªªªªªªªªªª
aaaaaaaaaaaaa
ºººººººººººººº
₢₢₢₢₢₢₢₢₢₢₢₢₢₢';
my $regex = qr/^(?!^([a-z]+|[A-Z]+|\d+|[\W_]+)$).{4,20}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}