re = /^(?!^([a-z]+|[A-Z]+|\d+|[\W_]+)$).{4,20}$/m
str = 'aaaaaaaaa
111111111
AAAAAAAA
!@#!@#!@
aaaaa11111
aaaaaAAAAA
aaaaa!@#@!
11111aaaaa
11111AAAAA
11111!@!@$
AAAAAaaaaa
AAAAA11111
AAAAA12312
!@#$%&aaaa
!@#$%&1231
!@#$%&AAAA
1123as%@#%AAFFSS
sdffsg#$52ERgWAfW14
sdffsg#$52ERgWAfW141
sdffsg#$52ERgWAfW1412
__________
----------
||||||||||
¹¹¹¹¹¹¹¹¹¹
²²²²²²²²²²
³³³³³³³³³
££££££££
¢¢¢¢¢¢¢¢¢¢
¬¬¬¬¬¬¬¬¬¬
//////////
°°°°°°°°°°
ªªªªªªªªªªª
aaaaaaaaaaaaa
ºººººººººººººº
₢₢₢₢₢₢₢₢₢₢₢₢₢₢'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end