using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[^#]*#){2}([^#]*)";
string input = @"3#White House, District Of Columbia, United States#US#USDC#DC001#38.8951#-77.0364#531871#382";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}