const regex = /^(?:[^#]*#){2}([^#]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[^#]*#){2}([^#]*)', 'gm')
const str = `3#White House, District Of Columbia, United States#US#USDC#DC001#38.8951#-77.0364#531871#382`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}