re = /^(?:[^#]*#){2}([^#]*)/m
str = '3#White House, District Of Columbia, United States#US#USDC#DC001#38.8951#-77.0364#531871#382'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end