$re = '/^(?:[^#]*#){2}([^#]*)/m';
$str = '3#White House, District Of Columbia, United States#US#USDC#DC001#38.8951#-77.0364#531871#382';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);