// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[^#]*#){2}([^#]*)").unwrap();
let string = "3#White House, District Of Columbia, United States#US#USDC#DC001#38.8951#-77.0364#531871#382";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}