using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<string>.*)\s+Actualstart";
string input = @"Completed changes are not shown as complete in channels for a while Actualstart: 2017-05-15 06:40:34";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}