import re
regex = re.compile(r"^(?<string>.*)\s+Actualstart")
test_str = "Completed changes are not shown as complete in channels for a while Actualstart: 2017-05-15 06:40:34"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")