package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?<string>.*)\s+Actualstart`)
var str = `Completed changes are not shown as complete in channels for a while Actualstart: 2017-05-15 06:40:34`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}