// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(?<string>.*)\s+Actualstart").unwrap();
let string = "Completed changes are not shown as complete in channels for a while Actualstart: 2017-05-15 06:40:34";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}