re = /^(?<string>.*)\s+Actualstart/
str = 'Completed changes are not shown as complete in channels for a while Actualstart: 2017-05-15 06:40:34'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end