#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?s)(?<=\s)\w*(?=\-.*)"
Local $sString = "This is [INFO] 29 Jun 2018 06:06:49,620 SYSLOG->|datetime:20180629060649618+0000|" & @CRLF & _
" my first sentence. " & @CRLF & _
" This is my [second] sentence.(?<=\[).*?(?=\].*)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")