use strict;
my $str = 'This is [INFO] 29 Jun 2018 06:06:49,620 SYSLOG->|datetime:20180629060649618+0000|
my first sentence.
This is my [second] sentence.(?<=\\[).*?(?=\\].*)';
my $regex = qr/(?s)(?<=\s)\w*(?=\-.*)/sp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}