const regex = new RegExp('(?s)(?<=\\s)\\w*(?=\\-.*)', 's')
const str = `This is [INFO] 29 Jun 2018 06:06:49,620 SYSLOG->|datetime:20180629060649618+0000|
my first sentence.
This is my [second] sentence.(?<=\\[).*?(?=\\].*)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}