import Foundation
let pattern = #"(?s)(?<=\s)\w*(?=\-.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
This is [INFO] 29 Jun 2018 06:06:49,620 SYSLOG->|datetime:20180629060649618+0000|
my first sentence.
This is my [second] sentence.(?<=\[).*?(?=\].*)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}