using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?Stack){3}\K";
string substitution = @"\n";
string input = @"Stack is a linear data structure stack follows a particular order in stack the operations are performed";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}