$re = '/(.*?Stack){3}\K/i';
$str = 'Stack is a linear data structure stack follows a particular order in stack the operations are performed';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;