re = /(.*?Stack){3}\K/i
str = 'Stack is a linear data structure stack follows a particular order in stack the operations are performed'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result