const regex = /(.*?Stack){3}\K/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?Stack){3}\\K', 'gi')
const str = `Stack is a linear data structure stack follows a particular order in stack the operations are performed`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);