using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^.]+\.[^.]+\.(.+)\.\d{2,4}-\d{2}-\d{2}";
string input = @"dpkg.log.looker.test.2019-09-25
dpkg.log.looker.test1.test2.2019-09-25";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}