re = /[^.]+\.[^.]+\.(.+)\.\d{2,4}-\d{2}-\d{2}/m
str = 'dpkg.log.looker.test.2019-09-25
dpkg.log.looker.test1.test2.2019-09-25'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end