// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[^.]+\.[^.]+\.(.+)\.\d{2,4}-\d{2}-\d{2}").unwrap();
let string = "dpkg.log.looker.test.2019-09-25
dpkg.log.looker.test1.test2.2019-09-25";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}