import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^.]+\\.[^.]+\\.(.+)\\.\\d{2,4}-\\d{2}-\\d{2}";
final String string = "dpkg.log.looker.test.2019-09-25\n"
+ "dpkg.log.looker.test1.test2.2019-09-25";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}