package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^.]+\.[^.]+\.(.+)\.\d{2,4}-\d{2}-\d{2}`)
var str = `dpkg.log.looker.test.2019-09-25
dpkg.log.looker.test1.test2.2019-09-25`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}