$re = '/[^.]+\.[^.]+\.(.+)\.\d{2,4}-\d{2}-\d{2}/m';
$str = 'dpkg.log.looker.test.2019-09-25
dpkg.log.looker.test1.test2.2019-09-25';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);