#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d+:\d+ (?i)(?:[ap]m) - \d+:\d+ (?i)(?:[ap]m)"
Local $sString = "Mon-Thu, Sun 11:30 am - 10:00 pm \\/ Fri-Sat 11:30 am - 10:30 pm" & @CRLF & _
"Mon-Thu, Sun 11:30 AM - 10:00 PM \\/ Fri-Sat 11:30 AM - 10:30 PM"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")