package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+:\d+ (?i)(?:[ap]m) - \d+:\d+ (?i)(?:[ap]m)`)
var str = `Mon-Thu, Sun 11:30 am - 10:00 pm \\/ Fri-Sat 11:30 am - 10:30 pm
Mon-Thu, Sun 11:30 AM - 10:00 PM \\/ Fri-Sat 11:30 AM - 10:30 PM`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}