using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+:\d+ (?i)(?:[ap]m) - \d+:\d+ (?i)(?:[ap]m)";
string input = @"Mon-Thu, Sun 11:30 am - 10:00 pm \\/ Fri-Sat 11:30 am - 10:30 pm
Mon-Thu, Sun 11:30 AM - 10:00 PM \\/ Fri-Sat 11:30 AM - 10:30 PM";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}