use strict;
my $str = 'Mon-Thu, Sun 11:30 am - 10:00 pm \\\\/ Fri-Sat 11:30 am - 10:30 pm
Mon-Thu, Sun 11:30 AM - 10:00 PM \\\\/ Fri-Sat 11:30 AM - 10:30 PM';
my $regex = qr/\d+:\d+ (?i)(?:[ap]m) - \d+:\d+ (?i)(?:[ap]m)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}