import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+:\\d+ (?i)(?:[ap]m) - \\d+:\\d+ (?i)(?:[ap]m)";
final String string = "Mon-Thu, Sun 11:30 am - 10:00 pm \\\\/ Fri-Sat 11:30 am - 10:30 pm\n"
+ "Mon-Thu, Sun 11:30 AM - 10:00 PM \\\\/ Fri-Sat 11:30 AM - 10:30 PM";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}